Jump to content


Photo

Upload Bottleneck with 410 inline?

upload 410 inline

  • Please log in to reply
5 replies to this topic

#1 Nicholas Moore

Nicholas Moore
  • Members
  • 9 posts

Posted 18 October 2011 - 10:02 AM

I have a web filter 410 inline with a 5mbps Metro Ethernet connection (actually I believe they have us set at 6 down and 10mbps up). When I do a speed test using my ISP's tools I get my full 5mbps down, but I struggle to get 3mbps upload. Is it possible that the web filter is a bottleneck for upload speeds? When I test outside of my firewall I get the advertised speeds.

I haven't ruled out my Cisco ASA 5520 firewall yet, but I'm not doing anything crazy or advanced with my ASA so I doubt that's the bottleneck.

Any suggestions?

#2 Joshua Campbell

Joshua Campbell
  • Members
  • 0 posts

Posted 08 November 2011 - 02:05 PM

I have a 410 inline with a ASA 5510 and we have a 40MB fiber link and I know the 410 tops out at 20MB according to tech support but I can still pull down over 80 up and down so you have to have a mismatch in speed or duplex going on.

#3 Brian Arthur

Brian Arthur
  • Members
  • 2 posts

Posted 02 December 2011 - 09:54 AM

Wouldn't a speed/duplex mismatch affect both upload and download? Assume the speed test is done from the same location inside the network.
Have you tried the speed test in "Audit Mode" to see if that makes a difference?

#4 Chris Waterbury

Chris Waterbury
  • Members
  • 0 posts

Posted 08 December 2011 - 10:59 AM

I've had our ISP check our 410 for me (they co-manage the device). They bypassed the device and get full speeds both directions. We have a 10Mb/s Up/Down fiber link. With the device inline, we get 2Mb/s up 10Mb/s down.

#5 Scott Peterson

Scott Peterson
  • Members
  • 1 posts

Posted 12 March 2012 - 03:57 PM

I battled the same issue for months. I finally figured out that the Cisco Switch that the Barracuda LAN port was plugged into was configured for switchport spanning-tree PortFast. Once PortFast was disabled, all Internet speeds were as expected. The PortFast option can create looping errors when a bridge is connected to the port.

#6 MattP

MattP
  • Barracuda Guru
  • 14 posts

Posted 14 March 2012 - 10:45 AM

delete.

Edited by MattO, 14 March 2012 - 10:46 AM.