Jump to content


Photo

Cannot load signed certificate and chain

certificate

  • Please log in to reply
2 replies to this topic

#1 exploit

exploit
  • Members
  • 2 posts

Posted 20 March 2013 - 11:45 AM

Hello,
A generated a CSR from the Barracuda Load Balancer 340.
The Cert. Authority signed it, and also gave me the 3 intermediate certificates (PEM format)

I tried uploading the certificate and intermediate certificates.

The result was an error : "impossible to upload signed certificate".

I also tried to convert them from PEM to PKCS12 format but this it was not possible as
the operation needs the private key wich is stored inside the barracuda box ...and I found
no way to get it from the web interface.

Any idea would be appreciated.

MCN

#2 R V Shiva Kumar

R V Shiva Kumar
  • Barracuda Team Members
  • 44 posts
  • LocationBangalore KA, IN

Posted 20 March 2013 - 11:53 AM

Hi Exploit,

From the firmware 4.2 and above, we have provided an option "Assign Associated Key" while uploading the signed certificate which automatically pairs teh Private key on the device for the certificate.

If you are on older firmwares, then please do contact the support team for Barracuda Load Balancer by calling +1 408 342 5300 and support shall be helping you out ot obtain the private key associated

Thank you
Regards Shiva Kumar RV

#3 exploit

exploit
  • Members
  • 2 posts

Posted 20 March 2013 - 12:07 PM

Thanks, I will try to call the support.
Actually we have firmware 3.6.0.012 and we are invited to upgrade to 3.6.1.009 (latest one)
How can we obtain firmware from 4.x branch ?