Jump to content


Gigabit Ethernet Passthrough

speed network card passthrough

  • Please log in to reply
3 replies to this topic

#1 Guillaume beauchamp

Guillaume beauchamp
  • Members
  • 1 posts

Posted 29 July 2014 - 11:05 PM



I'm using WF 310 that is now 2 half year old that have 100Mb card.


Newer model 310 or 410 now have Gigabit Ethernet passtrough card.


We have 1000Mb filber connection at the office and remote 1000mb fiber at collocation for backup purpose we want to use soon and we are now limit and get 90Mbps with currecnt WF 310. If we remove the 310 from the inline setup we get around 650-800 Mbps that will really improve and reduce the backup time frame.


Does the WF 310 or 410 that have respectivelly 10-50 and 50-100 Mbps for HTTP and HTTPS Throughput limit will transmit any other data at full speed on the Gigabit card to the backup server collocation?


Thank you,

#2 mheller



  • Moderators
  • 1,299 posts
  • LocationSan Jose, CA

Posted 30 July 2014 - 08:56 AM

Hello Guillaume,


A unit with a 100mb Ethernet card will simply max out at this limit, and it will always try to transfer at the fastest speed possible. 


If a web filter with a gig card has proper negotiation, then it will send at the fastest speed it can, regardless of application or HTTP protocol

Matthew Willson-Heller
Support Escalation Manager, US

Barracuda Networks Inc.
Phone: +1 408.342.5300 x5346
Fax: +1 408.342.1061
Web: www.barracudanetworks.com

#3 Allen Hwang

Allen Hwang
  • Members
  • 1 posts

Posted 10 May 2017 - 09:43 PM



I am using WF 310 and can't get internet speed more than 100Mbps.

Do you have any solution can make my internet speed reach 200Mbps with my barracuda WF 310?

#4 Daniel Sandoval

Daniel Sandoval
  • Members
  • 1 posts

Posted 18 February 2020 - 05:48 PM

I had this issue. We have  150/150 fiber with AT&T and was only seeing ~90Mbps if i tested from inside the LAN. When i would connect my laptop to our DMZ, Bam!! 160ish up and down



My setup: SonicWALL Firewall (purchased in 2015) > Barracuda Web Filter > Main Switch




What did it for me:

First make sure you have cat6 or cat5e ethernet cable (at minimum) going from your SonicWALL > Barracuda Web Filter (substitute the SonicWALL for whatever firewall you use) as well as the port to from Barracuda Web Filter > Main Switch



On my SonicWALL i configured port "X0" (LAN) to:


Link Speed: 1 Gbps - Full Duplex

Interface MTU: 1500


On the Barracuda Webfilter, I set the settings of the WAN port (in my case it was eth2) to:


speed: 1000

duplexity: Full

MTU: 1500




And that did it


My appliance is a Barracuda Web Security Gateway 410