Jump to content


Microsoft RDP Client Resource - Prompt for Hostname

hostname rdp windows remote desktop prompt attribute client name computer

  • Please log in to reply
5 replies to this topic

#1 Evluma IT

Evluma IT
  • Members
  • 3 posts

Posted 29 October 2015 - 01:11 PM



I'm trying to figure out if it is possible to create a Microsoft RDP Client Resource Application that will prompt the user for a hostname each time they launch the resource application. Currently, it only prompts them when they initially launch the application and then saves the entry as the default.


This is problematic as some users need to remote into more than one machine or from time to time incorrectly enter in the hostname. It's very cumbersome to have to change the attributes each time they want to remote into a new/different computer.


Is there a way to launch the remote desktop application and have it prompt the user for a hostname to connect to?


What I've done so far is created a new User Attribute and left the Default Value blank in hopes it would prompt the user to enter in a hostname, however that is not the case! A message displays that says:


Error: There were problems with one or more entries

Required attributes have not been configured for this resource. Please contact your Administrator for further assistance

#2 Lindsey Lawton

Lindsey Lawton
  • Barracuda Team Members
  • 10 posts
  • LocationSan Jose

Posted 29 October 2015 - 01:15 PM

Hello there


Each user should be able to edit they're hostname or ip address. Have them go to the account tab and then attributes. They can change the field "My Computer" to what they need. If they cant change it, make sure you have given the proper access right titled "attribute change". Hope this helps!

#3 Gavin Chappell

Gavin Chappell
  • Moderators
  • 435 posts
  • LocationNottingham, UK

Posted 29 October 2015 - 01:24 PM

Also please note that the default visibility (i.e. "permissions") for custom attributes is that users can only read them, not set them. It's not clear from your post whether you have set this to allow users to change the contents of this attribute, but this would be necessary and lack of this permission may cause the issue you've highlighted in red.


Also note that if the default value is blank, this won't stop users from setting the attribute at launch time and saving this. The only way to not save the value is to clear the checkbox when you're first providing a value, otherwise the user will need to visit Account->Attributes in order to change the value, once set.

#4 Evluma IT

Evluma IT
  • Members
  • 3 posts

Posted 29 October 2015 - 01:32 PM

The users have the ability to change the attribute. I'm just trying to avoid having them do this.


From what I understand, the only way to have the RDP application prompt them for a hostname in a continuous fashion, is to make sure the checkbox is unchecked each time they declare a value?


I was hoping there would be some sort of attribute I could enter in that would always prompt for a hostname, this way people can use it to access multiple computers or servers in our environment

#5 Gavin Chappell

Gavin Chappell
  • Moderators
  • 435 posts
  • LocationNottingham, UK

Posted 02 November 2015 - 11:56 AM

No, unfortunately there's no way to automatically block a user from setting a default value, they'd have to untick the box when they set it. Most customers just have either:


1 RDP resource, called "My Computer", which the user sets an attribute once and then re-uses it every time




several RDP resources, one per server with a fixed hostname, and then they can use policies to control which users see these resources so each user only sees the ones which are appropriate to them. 

#6 Gavin Chappell

Gavin Chappell
  • Moderators
  • 435 posts
  • LocationNottingham, UK

Posted 13 November 2015 - 08:49 AM



Through trying to test something else, I've found an option which will set the "save" tickbox to unticked by default. So this wouldn't actually block users from saving a value, but it would stop them from accidentally saving a value by still having the box checked when they enter it.


This option is under Basic->Appearance->Logon Page, which is why I've never stumbled across it before (a more appropriate place would probably be under Resources->Configuration)...just thought it may be of use to you!