Jump to content


Photo

problem auto-installing applications during enrolment

enrolment problem apple ios managed application install

This topic has been archived. This means that you cannot reply to this topic.
2 replies to this topic

#1 Neil Kennedy

Neil Kennedy
  • Members
  • 2 posts

Posted 13 February 2016 - 09:58 AM

Further to recent apple IOS update, it appears that it is not possible to complete the setup of an apple account during the initial setup of a device, but must be completed afterwards using settings>itunes & app stores. neither is it possible to do this using the website.  Hence, during the enrolment of a new device, managed applications aren't installing due to incomplete iTunes account registration.

 

The only way I've managed to get around this is to ask the users to perform the setup twice, wiping the device after the first pass.

 

any ideas?



#2 Karl Moore

Karl Moore
  • Barracuda Team Members
  • 33 posts

Posted 16 February 2016 - 04:31 AM

Neil, how are you enrolling these devices, is this via DEP?  Just to clarify you're saying that during initial setup the iTunes account configuration is missing or doesn't work?  If you can provide some more details we can investigate.  Instead of enrolling a second time one option would be to go to the applications page and sync with missing.  This will push down applications to devices that don't currently have them install.  Would that solve the issue?



#3 Neil Kennedy

Neil Kennedy
  • Members
  • 2 posts

Posted 16 February 2016 - 05:58 AM

Hi, yes the devices are being enrolled using DEP.  yes, during initial setup of the device, the apple wizard no longer allows you to complete the setup of a new apple account (last IOS update or two?) to allow the applications to be deployed successfully by the MDM.  When the MDM attempts to deploy the apps, the device asked the user for their apple password, after which it forwards them to the account setup page to complete registration.  This interrupts the app install, which fails and isn't retried.  Of course, we don't know when the devices will be initialised, hence difficult to know when to manually sync with missing!  I want to avoid problems for my users ideally!