Jump to content


Photo

reverse proxy to use both port 80 and 443

reverse proxy port 80 port 443

2 replies to this topic

#1 Simon Day

Simon Day
  • Members
  • 4 posts

Posted 17 January 2017 - 10:27 AM

Trying to configure a reverse proxy to work on a couple of URL's coming into our main gateway through a Barracuda F400 series firewall. This has caused all sorts of issues but now have been told you cannot have both port 80 and 443 configured and working. I'm told because we have port 443 set then it will intercept port 80 requests and then send them on as port 443 to all servers. The configuration we want is only send port 443 onto servers if the incoming request for the URL is also on port 443 and if its on port 80 then send it to the server on port 80.

 

regards

 

Simon



#2 Marco Miska

Marco Miska
  • Barracuda Team Members
  • 61 posts
  • LocationInnsbruck

Posted 30 January 2017 - 06:49 AM

Dear Barracuda Networks-Community members,

we are pleased to announce the new Idea Portal for Barracuda Network Security products. This new portal makes submitting new ideas much more convenient and enables automatic tracking of the status.
The portal is available at: http://netsecfeedback.barracuda.com  and your existing login credentials can be used to sign in.

 

The new portal introduces the following benefits:

  • Ideas from customers, partners, and employees can now easily be submitted, filtered, and managed in one place.
  • Contributors can now easily track the status of their submitted ideas or others ideas they like.
  • The new voting function makes it easy to know what people think and elevate priority of popular ideas.
  • The new idea portal encourages direct communication with the idea submitters.
  • Automatic notifications are sent when the status of an idea changes.

 

The following categories are used for responses:

  • “Needs review” - this idea is waiting for review and categorization.
  • “Future consideration” - we may consider implementing this idea in future - based on demand, capacity and priorities.
  • “Already exists” - this idea already exists in the product.
  • “Will not implement” - this idea will not be implemented.
  • “Planned” - this idea will be implemented and is scheduled.
  • “Shipped” - this idea is now shipped in a release.

 

NOTE:

The existing community portal will be turned off, by March 1st 2017. Posts from the existing community portal are not scheduled to be moved automatically. If an idea you posted recently in the community portal is near and dear to you, we kindly ask you to add them to the new portal. In exchange for this effort, your idea tickets will be reviewed by the Network Security PM-Team on a regular basis and can be managed much easier.

 

For further questions, please get in touch with us:

 

netsec-ideas@barracuda.com

 

Thanks in advance
Best regards
Network Security PM-Team



#3 Steve Vickers

Steve Vickers
  • Barracuda Team Members
  • 45 posts

Posted 08 February 2017 - 01:19 PM

Hi Simon,

 

it depends how you have defined the proxy service. You should only be telling the service to listen on port 80. The SSL listen port is only defined in the SSL settings. If you define the service to listen on port 443 it will listen on that port for the HTTP protocol (not HTTPS) which likely the cause of the problem.

 

Hope that helps,

 

Steve





Reply to this topic