Jump to content


Photo

Client VPN keep disconnecting/reconnecting

client vpn

Best Answer Micha Knorpp, 21 February 2017 - 03:15 AM

And you are sure that these login credentials are not used on any other device?

Behaviour as you described usually looks the same if two or more clients try to connect with same credentials at the same time (which is not supported with standard remote access licensing, only with RA premium). the devices then keep kicking each other endlessly.

Go to the full post


  • Please log in to reply
9 replies to this topic

#1 Robert James

Robert James
  • Members
  • 8 posts

Posted 15 February 2017 - 05:02 PM

We've been using the client to site VPN for a while and I've started to see this problem when connecting via my Win 8.1 laptop.  I've asked most of our IT team who say they have not had any problems themselves.  I've tried uninstalling the client and re-installing the latest 4.0 VPN client.  When I look at the vpn client I see repeated:

 

ERROR: peer closed connection

ERROR: Handshake Timeout

Reconnected

 

 

I stay connected for about 20/30 seconds and the process repeats.

 

Any suggestions what to try to fix this?

 

 

Thanks

 

Robert

 

 

 

 



#2 Manuel Huber

Manuel Huber
  • Members
  • 149 posts

Posted 16 February 2017 - 09:10 AM

Did your client get an IP address from the VPN server?
Try changing the setting in the profile - advanced settings - Tunnel settings - Virtual Adapter configuration IPv4

change here from "Use internal DHCP assignment" to "Direct assignment" or vice versa.

DonĀ“t ask me why, but doing this one way or the other helps since about ten years to solve such issues.



#3 Robert James

Robert James
  • Members
  • 8 posts

Posted 16 February 2017 - 09:49 PM

Yes I got an IP and the tunnel comes up.  I'm able to start a ping to a remote server which works for about 30 seconds, then drops, reconnects, and works for another 30 seconds.  I just tried switching to Direct Assignment, same thing no change.  I had called support yesterday and they suggested I try the 3.5v of the VPN client since I was on Win 8.1.  That didn't make any changes.  I'm currently on hold with support to see if they can give me some more help on this.



#4 Micha Knorpp

Micha Knorpp
  • Members
  • 177 posts
  • LocationGermany, BW

Posted 21 February 2017 - 03:15 AM   Best Answer

And you are sure that these login credentials are not used on any other device?

Behaviour as you described usually looks the same if two or more clients try to connect with same credentials at the same time (which is not supported with standard remote access licensing, only with RA premium). the devices then keep kicking each other endlessly.


regards,
-micha-

#5 Theresa Staudacher

Theresa Staudacher
  • Members
  • 1 posts

Posted 27 February 2017 - 05:56 AM

I've discovered the same issues. The only thing that helped me was a new, clean Windows Profile.



#6 Robert James

Robert James
  • Members
  • 8 posts

Posted 27 February 2017 - 01:53 PM

MIcha, appears to hit the issue.  I was using the same creds on more than one connection.  It would have been nice if I had received a proper error message instead of just being disconnected though.  I had also spent some time with support who couldn't figure out the issue either.  I was being escalated to a higher level of support to further look into the issue.  I think its solved and I'm good now.

 

Thanks again.



#7 Micha Knorpp

Micha Knorpp
  • Members
  • 177 posts
  • LocationGermany, BW

Posted 28 February 2017 - 05:45 AM

Glad this helped.

Sometimes failure is easy to find if you know what you are looking for..... or if you ran into the same error before.  ;-)


regards,
-micha-

#8 Owen Li

Owen Li
  • Members
  • 2 posts

Posted 08 November 2017 - 09:53 PM

And you are sure that these login credentials are not used on any other device?

Behaviour as you described usually looks the same if two or more clients try to connect with same credentials at the same time (which is not supported with standard remote access licensing, only with RA premium). the devices then keep kicking each other endlessly.

Can you please clarify what you mean by login credentials are not used on any other device?  For instance I'm still logged into my workstation at the office, and I use VPN nightly and have never experienced any disconnect/reconnect issues.  Is this problem only when more than one VPN connection is established at the same time?

 

Today I was offsite and noticed that all 5 users with laptops kept getting this disconnect reconnect problem.  I thought initially it was because of the very flaky internet, but then I stumbled onto this post.   Basically what we did was took with us the user's laptops to do some testing, and provided the users with loaner laptops.  At the time of when I was experiencing this problem they could have very well been connecting with their loaner laptops at the same time at another location.



#9 Owen Li

Owen Li
  • Members
  • 2 posts

Posted 08 November 2017 - 10:09 PM

MIcha, appears to hit the issue.  I was using the same creds on more than one connection.  It would have been nice if I had received a proper error message instead of just being disconnected though.  I had also spent some time with support who couldn't figure out the issue either.  I was being escalated to a higher level of support to further look into the issue.  I think its solved and I'm good now.

 

Thanks again.

Do you mean you had more than one instance of the barracuda vpn client running on multiple computers at the same time for the same user?  Or do you mean same creds on more than one connection like, a user is logged into his desktop at the office, and then the same user tries to login from his laptop using VPN?



#10 Micha Knorpp

Micha Knorpp
  • Members
  • 177 posts
  • LocationGermany, BW

Posted 09 November 2017 - 02:44 AM

What I meant is: having several laptops with Barracuda VPN Client and using the same Logon Credentials IN THE VPN  at the same time. It has nothing to do with Windows Logons.

 

This is only supported if you have a Remote Access Premium License, and as I got to know just a few minutes ago, not at all when using Personal Licenses. You will have to use Group VPN instead. 


regards,
-micha-