Jump to content


Photo

VPN Client open tap device error on Mac Osx 10.4.3


  • Please log in to reply
1 reply to this topic

#1 roberto colonello

roberto colonello
  • Members
  • 1 posts

Posted 13 February 2019 - 05:03 AM

I installed the last version of the barracuda client VPN for Mac Osx on my macbook pro 2018 but I receive this error when I start a connection:

 

Open Failed: no such file or directory

open tap device

 

Tap is configured on /dev/tun0, but I tried also from tun1 to tun3

 

I tried also the previous versions of the VPN, but I have still this error

 

thanks

 

Roberto



#2 Gavin Chappell

Gavin Chappell
  • Moderators
  • 397 posts
  • LocationNottingham, UK

Posted 13 February 2019 - 05:34 AM

I assume you mean macOS 10.14.3 (i.e. Mojave)?

 

This sounds like the relatively new security improvements where the operating system will not load a kernel extension until you authorise it to do so in the "Security and Privacy" preferences pane inside "System Preferences". Unfortunately, I believe the prompt to load the extension only appears for 30 minutes, and it may only appear the first time you try to load the extension - https://developer.apple.com/library/archive/technotes/tn2459/_index.htmlhas more information.

 

My suggestion would be to try launching the VPN connection again, and immediately after you do so, open the "Security and Privacy" pane; if the prompt appears then accept the prompt and everything should be fine. If macOS is not showing you the prompt a second time then there are complicated procedures for forcing the OS to prompt you again, which are already well documented via Google results.