Jump to content


Photo

Barracuda device works very slow in smtp transaction & after reboot it starts to work fine

email security gateway high latency

  • Please log in to reply
3 replies to this topic

#1 syed jahanzaib

syed jahanzaib
  • Members
  • 6 posts

Posted 19 March 2019 - 02:01 AM

We are using Barracuda 300 hardware appliance for inbound emails only, outbound works directly via our router gateway
 
It's happening frequently that barracuda device response gets very slow, & inbound emails arrives very slowly. example if we test it from outside, (mxtools)
 
"SMTP Transaction Time 18.341 seconds - Not good! on Transaction Time"
 
emails are arriving slow on barracuda. it works fine after a reboot & the smtp transaction times drops to 2-3 seconds only. also if we bypass barracuda (routing rules) it works fine.
 
Other Details: our Internet connectivity: very good 
Performance Statistics
HelpIn/Out Queue Size: 0/0
Average Latency: 88 seconds 
Last Message: 1 minute ago 
Unique Recipients: 276 
System Load: 12% 
CPU 1 Fan Speed: 4143 RPM 
System Fan 1 Speed: 8333 RPM 
CPU 1 Temperature: 28.0°C 
System Temperature 2: 23.0°C
Temperature 1: 27.8°C 
Temperature 2: 29.8°C 
Firmware Storage: 62% 
Mail/Log Storage: 18%
 
why it is happening that we have to restart the device ? 


#2 Michael Manning

Michael Manning
  • Members
  • 211 posts
  • LocationOhio, USA

Posted 19 March 2019 - 01:08 PM

We had an issue with ours recently, over the course of several months we would see the system load increase to near 100% periodically and the system would become unresponsive. I'd power it off and back on and it would be fine for some amount of time (hours, days?). Then one day it started showing it was under heavy load an then failed. Completely. The appliance was a bit over 4 years old, we wound up having it replaced under the instant replacement plan. Fortunately I had the configuration backed up locally because a cloud backup is only usable on the same hardware it was taken from.



#3 syed jahanzaib

syed jahanzaib
  • Members
  • 6 posts

Posted 19 March 2019 - 10:42 PM

Our unit is just 10 months old baby & we are confused weather its the hardware or software issue . 

 

Yesterday we contacted barracuda support, and they did some tuneup late night via tunnel support & replied "they have allocated more resources to the appliance to give it more to work with, which will help the device process emails"

 

and from this morning we are seeing normal response in smtp transaction time. we will keep monitoring if this helps.



#4 Jimmy Hum

Jimmy Hum
  • Members
  • 11 posts

Posted 29 March 2019 - 01:09 PM

Just old fashion memory leaks.

 

Majority of latency comes from hdd "swaps".

 

If you feel up to it, add another stick of ram in there. When we bumped our SF from 1Gb to 2Gb, it reduced our latency to half and needed less rebooting.