Jump to content


Photo

Changing Exchange from smart host to DNS breaks inbound emails

Exchange DNS Send Connector MX dns routing

  • Please log in to reply
No replies to this topic

#1 Alex

Alex
  • Members
  • 1 posts

Posted 25 March 2019 - 06:53 AM

Been having a bit of an issue with sending emails that contain more than 100 recipients. It hits the first 100 and then doesn't attempt to send the rest. Which it should according to Barracuda support. 

Due to this we have been advised of a workaround until the bug has been fixed. 

The workaround is referenced here - https://www.barracud...5016000000142qO

 

Tried implementing the workaround and this worked for outbound mail but it broke inbound from the outside, all mail was received into Cloud Control but marked as Deferred. 

The workaround includes using 35.176.171.28 and 35.177.145.32 as my DNS instead of my internal. It also requires changing the send connector from using the SmartHost to DNS for MX record lookups. 

As soon as this is put in place the inbound mail get's deferred. Return the settings back and everything will be delivered to my Exchange 2010 box (after 5-10 mins or so). Please note that outbound mail appears in my outbound queue on Barracuda due to some wonderful wizardry.  

 

Anyone any ideas why performing this workaround will break inbound mail?