Jump to content


Photo

Unable to quiesce disk - Caused by VMware Tools?


  • Please log in to reply
3 replies to this topic

#1 Michael Manning

Michael Manning
  • Members
  • 237 posts
  • LocationOhio, USA

Posted 11 July 2019 - 03:42 PM

I was messing around with backing up at the host level and would run into the error 'Unable to quiesce disk'. I tested whether or not I could manual snapshot through the Vsphere web management client and ran into the same thing. Searched around and found various solutions but the one that I found most interesting is to uninstall VMware tools and reinstall it without the Volume Shadow Copy option. Sure enough I can create a snapshot with quiescing enabled. Is this an acceptable solution?



#2 Michael Manning

Michael Manning
  • Members
  • 237 posts
  • LocationOhio, USA

Posted 16 July 2019 - 09:02 AM

surely other users have run into this?



#3 David Lask

David Lask
  • Members
  • 1 posts

Posted 04 October 2019 - 04:39 PM

In our case the solution was, in VMware Tools, the Volume Shadow Copy component must be disabled.  This is done through Add/Remove Programs. Once in Add/Remove Programs, then right click on VMware Tools and select Modify/Change.  Then under the Volume Shadow Copy feature, select Entire Feature will be unavailable.

 

 

After disabling this component, VMware was able to quiesce and take a snapshot. Doing this apparently causes the older sync drivers to be used.  Now that quiescence works in VMware/Vsphere, Barracuda was then able to backup without issue.

 

Hope this helps in your situation.

 

 



#4 Michael Manning

Michael Manning
  • Members
  • 237 posts
  • LocationOhio, USA

Posted 07 October 2019 - 09:14 AM

In our case the solution was, in VMware Tools, the Volume Shadow Copy component must be disabled.  This is done through Add/Remove Programs. Once in Add/Remove Programs, then right click on VMware Tools and select Modify/Change.  Then under the Volume Shadow Copy feature, select Entire Feature will be unavailable.

 

 

After disabling this component, VMware was able to quiesce and take a snapshot. Doing this apparently causes the older sync drivers to be used.  Now that quiescence works in VMware/Vsphere, Barracuda was then able to backup without issue.

 

Hope this helps in your situation.

Thanks for the reply. That's what I had done as well, but was curious if that was the best way to resolve the issue, hence the question. As long as there are no adverse effects or reasons not to continue with this config I guess I'll keep it that way.