Jump to content


Photo

WAF API v3 PowerShell

WAF API

Best Answer MKPRO, 07 October 2019 - 11:46 AM

WAF Support Team helped me fix the PowerShell script it is now working.

Go to the full post


  • Please log in to reply
3 replies to this topic

#1 MKPRO

MKPRO
  • Members
  • 4 posts

Posted 11 September 2019 - 01:57 PM

When I run this Script I do not get the desired output.

 

https://github.com/barracudanetworks/waf-automation/blob/master/waf-api/powershell/Set_Server_Maintenance_Mode/Set_Server_Maintenance_Mode.ps1

 

To see a Before and After Look here.

https://github.com/barracudanetworks/waf-automation/issues/4



#2 Aravindan Anandan

Aravindan Anandan
  • Barracuda Team Members
  • 73 posts

Posted 12 September 2019 - 12:32 AM

To confirm if the script works, I tested with a couple of firmware versions on the WAF before replying, and found it to be working in all cases.

 

The concerned powershell script basically makes an API call which is documented here: https://campus.barra...s__Server_Name_

 

If you want to run it through our support, please send an email to wafsupport_team@barracuda.com and we will check the behaviour and confirm if there is an issue.



#3 MKPRO

MKPRO
  • Members
  • 4 posts

Posted 20 September 2019 - 12:03 PM

I have multiple ports using the same IP and If I run the script it puts all Services with the same IP 'Out of Service All' or 'In Service'
 
I need a way to just set the Services I want to 'Out of Service All' or 'In Service'


#4 MKPRO

MKPRO
  • Members
  • 4 posts

Posted 07 October 2019 - 11:46 AM   Best Answer

WAF Support Team helped me fix the PowerShell script it is now working.