Jump to content


Photo

Error 122 (unexpected operating system error), Windows error 4390 (Solution)


  • Please log in to reply
1 reply to this topic

#1 AustrianSimon

AustrianSimon
  • Members
  • 2 posts

Posted 06 October 2019 - 07:51 PM

I have been struck with error 122 (unexpected operating system error) while doing Windows backups with system state via the Windows Agent (Linux server running the tape etc.) after it had worked for many years. There was no obvious reason, the last back up ran on Aug 13th 2019, the next day it failed and consistently did since on all jobs. Late Aug 13th 2019 my Windows laptop had frozen for some unknown reason and needed to be rebooted, came up clean and without any issue except for YSB.

 

A test with an old machine, that I brought up again after two year,  revealed that this one was working (so it was not a time out issue e.g. by expiration of the licenses after YSB was abandoned by Barracuda).

 

In yttrace.txt I saw Windows error 4390 on varying files. No errors are produced in the Windows eventlog at all that could be associated with YSB or the job.

 

I re-registered whatever COM service I could think of, including of course VSS. No joy though. Research on the Internet did not reveal any real solution for error 4390.

 

I verified, the jobs were running through querying vss for files, creating snapshot and stopped after processing about 20k-32k of files in "creating host filters".

 

"vssadmin list shadows", "vassadmin list providers" and "vssadmin list writers" 
are clean, show the relavant entries without errors.
 
The vss and shadow provider services are running, starting normally and shutting 
down cleanly without any entries in the Windows Event log.
 
sfc /scannow comes back clean, no errors at all.
 
I uninstalled the Windows Agent and reinstalled it. No change.
 
This all took about daily 2-3 hours of work over 2-3 weeks, and I was close to dispair over this. I decided, I'd try to backup the system files via a different tool and did so. At the same time I disabled the backup of the system state in all jobs to backup my windows laptop and saved the jobs.
 
I ran one of the jobs to test, whether it would now run through, and stopped it when it started creating the host files after processing the filters etc, now knowing the job would run through.
 
In a wild shot into the blue I then hit the target ...
 
I simply re-enabled the system state in the next job to be executed in 2 hours and ran it right away. And to my amazement it now ran through.
 
I did the same for the job that would run in a day +2 hours, and this one ran through too.
 
I have now re-enabled the system state in all Windows backup jobs (over the next 14 days) and assume, they will now all run through (not yet verified).
 
I noticed an immediate change in the status while running the jobs, it tells me again right from the beginning of the "create host filters" task how many files it would need to process (this had not occurred while the jobs aborted). I believe, after disabled the system state and running the job whatever YSB had cached was cleared resolving the issue.
 
I hope this helps some other users facing the same issue some serious headache ...
 
Servus, Simon
 
 
 
 

 

 

 

 

 

 

 

 

 

 



#2 AustrianSimon

AustrianSimon
  • Members
  • 2 posts

Posted 22 October 2019 - 11:56 AM

I can now confirm that all jobs have run through without fault and with system state re-enabled.

 

So removing the system state from all jobs and save the jobs, then run one of the modified jobs (and abort it when it became clear it would run through), then re-enable the system state on all jobs restored the full backup indeed.

 

Servus, Simon